LUGRo-Mesh Forum (espaņol/english)
May 28, 2022, 05:24:30 am
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Welcome to SMF For Free
 
  Home   Forum   Help Search Gallery Staff List Login Register  

OpenWRT

Pages: [1] 2 3  All   Go Down
  Print  
Author Topic: OpenWRT  (Read 4026 times)
PCDOM
Full Member
***
Posts: 105


« on: June 26, 2009, 01:07:21 pm »

It seems that it have a problem with OpenWRT revision 16568

Which version that you use to compile your firmware beta4 ?

Helene Gauthier

Report Spam   Logged

Share on Facebook Share on Twitter

JulioCP
Administrator
Full Member
*****
Posts: 113


WWW
« Reply #1 on: June 26, 2009, 03:25:45 pm »

It seems that it have a problem with OpenWRT revision 16568

Which version that you use to compile your firmware beta4 ?

In 0.6beta4 we used OpenWrt r15744

http://trac2.assembla.com/nightwing/browser/trunk/openwrt/trunk/.config


Get used to have headaches while using latests OpenWrt  Cheesy

It's better to stay in a particular revision that works, and after you finish your work try a newer one. A to often 'svn up' will make you go crazy  Wink

Quote
Helene Gauthier

                  Saludos, Julio
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #2 on: June 26, 2009, 03:49:34 pm »



In 0.6beta4 we used OpenWrt r15744


where can I download this version ?
Report Spam   Logged
JulioCP
Administrator
Full Member
*****
Posts: 113


WWW
« Reply #3 on: June 26, 2009, 04:00:17 pm »



In 0.6beta4 we used OpenWrt r15744


where can I download this version ?

svn co -r15744 svn://svn.openwrt.org/openwrt/trunk/


             Saludos, Julio
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #4 on: June 26, 2009, 04:31:57 pm »



svn co -r15744 svn://svn.openwrt.org/openwrt/trunk/


             Saludos, Julio
thanks a lot

I compiled twice the firmware with OpenWRT r15744 and NightWinh Beta 4

but now the problem is that picostation2 is not compiled

ubnt2 and ubnt5 are ok

any suggestion to resolve it ?

Helene Gauthier
« Last Edit: June 26, 2009, 05:59:57 pm by PCDOM » Report Spam   Logged
scriado
Administrator
Full Member
*****
Posts: 135


« Reply #5 on: June 26, 2009, 06:58:36 pm »

http://nightwing.lugro-mesh.org.ar/en/doc/howto_build_image_for_PicoStation2.html

The documentation mentions the beta3 of Nightwing.
Please try with version beta4.
« Last Edit: June 26, 2009, 07:20:26 pm by scriado » Report Spam   Logged
kissas
Jr. Member
**
Posts: 58


« Reply #6 on: June 27, 2009, 09:33:55 am »

its working for the beta4, maybe you can build in a normal way the image, modify, and the convert to pico2
you cannot build directly the image.
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #7 on: June 27, 2009, 12:18:42 pm »

http://nightwing.lugro-mesh.org.ar/en/doc/howto_build_image_for_PicoStation2.html

The documentation mentions the beta3 of Nightwing.
Please try with version beta4.
Ok, I follow this documentation width original instruction beta3
but when I try mkfwimage command , this command is not recognized

maybe my problem is with mkfwimage.c and fwsplit.c ?

or it have a missing instrcution ?

Helene Gauthier
Report Spam   Logged
kissas
Jr. Member
**
Posts: 58


« Reply #8 on: June 27, 2009, 01:56:52 pm »

you are in this directory? apps/gpl/mkfwimage/src
and you apply the patches?
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #9 on: June 27, 2009, 04:28:22 pm »

you are in this directory? apps/gpl/mkfwimage/src
and you apply the patches?
Yes , I was in the directory apps/gpl/mkfwimage/src
I applied the patch
I download the files beta3
and I execute this command
mkfwimage -i lx2-8.txt -v XS2.ar2316.OpenWRT-kamikaze -o nightwing_v0.6beta3-picostation2-squashfs.bin


-bash: mkfwimage: command not found

« Last Edit: June 29, 2009, 11:14:26 am by PCDOM » Report Spam   Logged
kissas
Jr. Member
**
Posts: 58


« Reply #10 on: June 29, 2009, 10:18:33 am »

./mkfwimage -i lx2-8.txt -v XS2.ar2316.OpenWRT-kamikaze -o nightwing_v0.6beta4-picostation2-squashfs.bin
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #11 on: June 29, 2009, 11:16:02 am »

./mkfwimage -i lx2-8.txt -v XS2.ar2316.OpenWRT-kamikaze -o nightwing_v0.6beta4-picostation2-squashfs.bin
It tried it
and this is the result

[root@hvs2 src]# ./mkfwimage -i lx2-8.txt -v XS2.ar2316.OpenWRT-kamikaze -o nightwing_v0.6beta4-picostation2-squashfs.bin
ERROR: Invalid part count '0'
ERROR: Failed validating firmware layout - error code: -1
[root@hvs2 src]#

it seems that the problem is with the file lx2-8.txt
« Last Edit: June 29, 2009, 11:53:01 am by PCDOM » Report Spam   Logged
kissas
Jr. Member
**
Posts: 58


« Reply #12 on: June 29, 2009, 03:02:08 pm »

show me the content or even better upload to smewhere and let me see the file, y think you are not doing the correct format for the file.
the spaces are NOT space, are tabs.
Report Spam   Logged
PCDOM
Full Member
***
Posts: 105


« Reply #13 on: June 29, 2009, 07:10:25 pm »

show me the content or even better upload to smewhere and let me see the file, y think you are not doing the correct format for the file.
the spaces are NOT space, are tabs.
Yes , it works !

It was the file and tab between the code

thanks

Now I will retry to compile firmware with our parameters and see it nanostation2 is ok

If it is... I will compile picostation2 with my modified firmware

Helene
Report Spam   Logged
kissas
Jr. Member
**
Posts: 58


« Reply #14 on: June 29, 2009, 10:16:03 pm »

u'welcome.
i'have tested pibo2 with that method and its working, so, you sure have luck on that way Wink
if have some question just ask !
Best regards and happy meshing Wink
Report Spam   Logged
Pages: [1] 2 3  All   Go Up
  Print  
 
Jump to:  

Bookmark this site! | Upgrade This Forum
SMF For Free - Create your own Forum
Powered by SMF | SMF © 2016, Simple Machines
Privacy Policy